Grin Dev Shares New Wallet Version Release

Grin coin privacy-focused developer under the pseudonym Yeastplume announced the launching of Grin and Grin Wallet 3.0.0. The announcement indicates that the old versions of the wallet will be closed soon and he also said the v3.0.0 Wallet will be only compatible with Grin nodes running v3.0.0 or greater. Hence, the users have been asked to upgrade at the soonest.

Leave a Reply

Your email address will not be published. Required fields are marked *